summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 470bbeb5dcc6..6d09c2d768f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Giovanni Harting <539@idlegandalf.com>
pkgname=pyfan
-pkgver=1.5.1
+pkgver=1.6.1
pkgrel=1
-pkgdesc="Fan control utilising hwmon and pid"
-arch=('any')
-url="https://git.harting.dev/anonfunc/PyFan"
-license=('GPL3')
-depends=('python-yaml' 'python-simple-pid')
+pkgdesc='Fan control utilising hwmon and pid'
+arch=(any)
+url='https://somegit.dev/anonfunc/PyFan'
+license=(GPL-3.0-or-later)
+depends=(python-yaml python-simple-pid)
optdepends=('lm_sensors: check and load required hwmon modules')
backup=('etc/pyfan')
-source=("https://git.harting.dev/anonfunc/PyFan/archive/$pkgver.tar.gz")
-b2sums=('73c6c83aa19922f20fc56bbde339e4d99f8fee585c52fe57a2e92e50cab5c7e9f20b52fd5446f19c68617673e5b68cefa418aae609c63b37d227a869e35760ee')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+b2sums=('c7ff904568196657c78acb1d690b3437b6a5e0cd2eb3355988b618426d6a225e357d26bbe060cf70363114d46ce9d55559d0396f2d793168ddc008a789416f26')
package() {
- cd "$pkgname"
-
- install -Dm755 pyfan.py "${pkgdir}/usr/bin/pyfan.py"
- install -Dm644 pyfan.service "${pkgdir}/usr/lib/systemd/system/pyfan.service"
- install -Dm644 config-example.yaml "${pkgdir}/usr/share/doc/$pkgname/config-example.yaml"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/$pkgname/README"
+ cd $pkgname
+ install -Dm755 pyfan.py "$pkgdir"/usr/bin/pyfan.py
+ install -Dm644 pyfan.service "$pkgdir"/usr/lib/systemd/system/pyfan.service
+ install -Dm644 config-example.yaml "$pkgdir"/usr/share/doc/$pkgname/config-example.yaml
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/$pkgname/README
}
+
+# vim:set ts=2 sw=2 et: