summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 18 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14f744769987..74147d9e37b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
_name=pyg3t
pkgname=$_name-git
-pkgver=0.5.1.r328.417e7a8
+pkgver=0.5.1.r401.3939d89
pkgrel=1
pkgdesc="Python GetText Translation Toolkit"
arch=(any)
-url="https://github.com/pyg3t/pyg3t"
-license=('GPL3')
-depends=('python-dateutil')
-makedepends=('git')
+url="https://gitlab.com/pyg3t/pyg3t"
+license=(GPL-3.0-or-later)
+depends=(python)
+makedepends=(git python-setuptools python-build python-installer python-wheel)
+checkdepends=(python-pytest)
provides=($_name)
conflicts=($_name)
source=(git+${url}.git)
@@ -24,11 +25,19 @@ pkgver() {
}
build() {
- cd "$srcdir/$_name"
- python setup.py build
+ cd $_name
+ python -m build --wheel --no-isolation
+}
+
+# Workaround for the tests requiring installed scripts (poselect, etc.)
+check() {
+ cd $_name
+ python -m installer --destdir='tmp_dir' dist/*.whl
+ export PATH="$PWD/tmp_dir/usr/bin:$PATH"
+ PYTHONPATH=$PWD python -m pytest -vv
}
package() {
- cd "$srcdir/$_name"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd $_name
+ python -m installer --destdir="$pkgdir" dist/*.whl
}