summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 38fcb3229764..c351ebf4f58b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
pkgname=pyocd
_pkgname=pyOCD
-pkgver=0.7.1
+pkgver=0.8.1a1
pkgrel=1
pkgdesc="Python On Chip Debugger and programmer for ARM Cortex-M microcontrollers using CMSIS-DAP"
url="https://github.com/mbedmicro/pyocd"
-depends=('python2' 'python2-setuptools' 'python2-pyusb' 'python2-intelhex' 'python2-enum34')
+depends=('python2' 'python2-setuptools' 'python2-pyusb' 'python2-intelhex' 'python2-enum34' 'python2-websocket-client' 'python2-backports.ssl_match_hostname')
optdepends=()
license=('Apache')
arch=('any')
# Sigh: Make sure you're not using GitHub's tarballs (or similar ones), as those don't contain the necessary metadata. Use PyPI's tarballs instead.
#source=("https://github.com/mbedmicro/${pkgname}/archive/v${pkgver}.tar.gz")
-source=("https://pypi.python.org/packages/cc/05/1be68f04ee71b8b10e24c55c9edc774f6bd3ce3a454981a9f7ea1a26c08d/${_pkgname}-${pkgver}.zip")
-sha512sums=('cfabc8224ac455e41338a767c18a7f90f2285ac55478b07ebbcebd27482ae7d20740486d182188da47a2b80e69778da2e8226dc82ba17f0f68afd684a827e123')
+source=("https://pypi.python.org/packages/c5/2c/274a31b605f40f66aff97362bef211730ae5410f5e4539031c5ef2e19b6d/${_pkgname}-${pkgver}.tar.gz")
+sha512sums=('d5d187bdb4df8223e38e3448b44ca25236aab72b6a5fdbe102455ea09b66b81424ac99c47542c841c17d9d360e7e73ceda3ba1bb1f1e5fee747764784015ef9a')
prepare() {
cd "$srcdir/$_pkgname-$pkgver"