summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 5 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a2489b5cb56f..dab552c15c17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Arnhold <thomas at arnhold dot org>
pkgname=pysbf-git
-pkgver=20140606
+pkgver=20210821
pkgrel=1
pkgdesc="Python module to parse Septentrio Binary Format (SBF) files generated by Septentrio receivers."
arch=('i686' 'x86_64')
@@ -9,30 +9,15 @@ url="https://github.com/jashandeep-sohi/pysbf"
license=('GPL3')
depends=('python2')
makedepends=('git')
-
-_gitroot="git://github.com/jashandeep-sohi/pysbf.git"
-_gitname="pysbf"
+source=("$pkgname::git+https://github.com/jashandeep-sohi/pysbf.git")
+sha256sums=('SKIP')
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$pkgname"
python2 setup.py build
-
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$pkgname"
python2 setup.py install --prefix=/usr --root="$pkgdir"
}