summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 39 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 04c194ed7a26..593b8f6764c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,16 @@
# Maintainer: Robert Kubosz <kubosz.robert@gmail.com>
-pkgname=python-abjad
+pkgbase=python-abjad
+pkgname=(python-abjad python2-abjad)
pkgver=2.21
pkgrel=2
pkgdesc="Tool for formalized music score control."
arch=("any")
url="https://github.com/Abjad/abjad"
license=("GPL 3")
-depends=(
- "lilypond"
- "python"
- "python-ply"
- "python-six"
- )
-makedepends=("python-setuptools")
-conflicts=('python2-abjad')
+depends=("lilypond")
+makedepends=("python-setuptools" "python2-setuptools")
+conflicts=("python2-abjad")
optdepends=(
"graphviz: to create rhythm-trees graphs and other tree structures"
"fluidsynth: to play generated MIDI files (instead of timidity++)"
@@ -27,14 +23,47 @@ optdepends=(
source=("$url/archive/v$pkgver.tar.gz")
sha256sums=("5fc1fc977b9521d4b9ce1aa8bdea1aa07306e313bd03feea15e8c680b4f27c5b")
+prepare () {
+ cp -rup $srcdir/abjad-$pkgver $srcdir/abjad-$pkgver-python2
+}
+
build() {
cd $srcdir/abjad-$pkgver
python setup.py build
+
+ cd $srcdir/abjad-$pkgver-python2
+ python2 setup.py build
}
-package() {
+package_python-abjad() {
+ depends+=(
+ "python"
+ "python-ply"
+ "python-six"
+ )
+ conflicts=("python2-abjad")
+
cd $srcdir/abjad-$pkgver
python setup.py install --root="$pkgdir/" --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
+package_python2-abjad() {
+ depends+=(
+ "python2"
+ "python2-ply"
+ "python2-six"
+ "python2-mock"
+ "python2-funcsigs"
+ "python2-enum34"
+ "python2-pathlib2"
+ "python2-scandir"
+ )
+ conflicts=("python-abjad")
+ provides=("python-abjad")
+
+ cd $srcdir/abjad-$pkgver-python2
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+