summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e607b697b50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: geearf
+
+pkgname=python-aiocache
+pkgver=0.10.1
+pkgrel=1
+pkgdesc="Asyncio cache manager for redis, memcached and memory"
+arch=(any)
+url="https://github.com/argaen/aiocache"
+license=('BSD')
+makedepends=('python-setuptools')
+depends=('python')
+optdepends=('python-aioredis' 'python-ujson')
+source=("https://github.com/argaen/aiocache/archive/${pkgver}.tar.gz")
+md5sums=('bfefdfe5cd80951578278b9b2a6eb944')
+
+build() {
+ cd "${srcdir}/aiocache-${pkgver}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${srcdir}/aiocache-${pkgver}"
+ python setup.py install --root=${pkgdir} --optimize=1 || return 1
+}