summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eb3e42dea64a..83e9b581bd6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,13 +28,14 @@ build() {
}
check() {
+ cd "$_name-$pkgver/build/lib"
# Test excludes:
# _tf: Requires tensorflow < 2, a large dependency
# _theano: Requires theano, a large dependency
# test_hash: Python hashes are not reproducible...
# TestBox::test_invalid_env: Tests gym.Box.__init__, and gym's error
# seems to have changed from what they expected.
- pytest "$_name-$pkgver/tests" \
+ python -m pytest "$srcdir/$_name-$pkgver/tests" \
-k 'not _tf and not _theano and not test_hash and not test_invalid_env'
}