summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 15 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6085a7e25a34..a31c083a9ff3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,25 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
_name=altgraph
-pkgname=python-altgraph
-pkgver=0.17.2
+pkgname=python-$_name
+pkgver=0.17.3
pkgrel=1
pkgdesc='A graph (network) package for constructing graphs, BFS and DFS traversals, topological sort, shortest paths, etc. with graphviz output.'
arch=(any)
url="https://pypi.python.org/pypi/$_name"
license=(MIT)
-depends=(python)
-makedepends=(python-setuptools)
+depends=(python python-setuptools) # setuptools for pkg_resources
+makedepends=(python-setuptools python-build python-installer python-wheel)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('ebf2269361b47d97b3b88e696439f6e4cbc607c17c51feb1754f90fb79839158')
+sha256sums=('ad33358114df7c9416cdb8fa1eaa5852166c505118717021c6a8c7c7abbd03dd')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- cd "$srcdir/$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 || return 1
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/python-altgraph/LICENSE"
}