summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c5a274c50ce2..592fe529ff97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-apex-git
_pkgname=apex
-pkgver=22.03.r231.g141bbf1c
+pkgver=22.03.r237.gb5df1ccf
pkgrel=1
pkgdesc="A PyTorch Extension: Tools for easy mixed precision and distributed training in Pytorch"
arch=('x86_64')
@@ -13,14 +13,20 @@ depends=('python' 'cuda' 'python-pytorch-cuda' 'python-sympy')
makedepends=('git' 'numactl' 'python-setuptools' 'python-pip')
provides=('python-apex')
conflicts=('python-apex')
-source=("git+$url")
-sha256sums=('SKIP')
+source=("git+$url" "https://patch-diff.githubusercontent.com/raw/NVIDIA/apex/pull/1791.diff")
+sha256sums=('SKIP'
+ '5e9eac8d5eb578b834a268bdf42b85c937fcad3fe895a26e5813ec134c3cb152')
pkgver () {
cd "${_pkgname}"
git describe --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$srcdir/${_pkgname}"
+ patch -p1 -N -i "$srcdir/1791.diff"
+}
+
build() {
cd "$srcdir/${_pkgname}"
CC=/opt/cuda/bin/gcc CXX=/opt/cuda/bin/g++ \