summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9be5903fbbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=python-aprs
+_pkgname=aprs
+pkgver=7.0.0
+pkgrel=1
+pkgdesc="A Python Module that supports connecting to APRS Interfaces, and receiving, parsing and sending APRS Frames."
+arch=('any')
+url="https://github.com/ampledata/aprs"
+license=('Apache')
+depends=(python python-kiss python-requests python-bitarray)
+source=("https://files.pythonhosted.org/packages/source/a/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('cd4d0209fd20697bf0b0550b5032ce09')
+
+package() {
+ cd $_pkgname-$pkgver/
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: