summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1ca4890389e..1c04f8b6a277 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=('python-arch')
_module='arch'
-pkgver='4.0'
+pkgver='4.1'
pkgrel=1
pkgdesc="ARCH models in Python."
-url="https://pypi.python.org/pypi/arch/4.0"
+url="https://pypi.python.org/pypi/arch/4.1"
depends=('python'
'python-numpy'
'python-pandas'
'python-scipy'
'python-statsmodels')
-makedepends=(
- 'cython'
- 'python-setuptools')
+checkdepends=('python-pytest')
+makedepends=('cython' 'python-setuptools')
license=('custom:University of Illinois/NCSA Open Source License')
arch=('i686' 'x86_64')
source=("https://github.com/bashtage/arch/archive/${pkgver}.tar.gz")
-md5sums=('9a98f2cd94fb2f8272fb5a2cad439ffc')
+sha256sums=('1f3348e0eda8705671ff4041be90af230aa0a28939a5d7f3b9a2ca93cdb7c736')
build() {
cd "${srcdir}/${_module}-${pkgver}"
@@ -28,3 +27,8 @@ package() {
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}
+
+check() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ py.test
+}