summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6923a319c9b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Debucquoy Anthony (tonitch) <d.tonitch@gmail.com>
+
+pkgname=python-asphalt
+_name=${pkgname#python-}
+pkgver=4.12.0
+pkgrel=0
+url="https://github.com/asphalt-framework/asphalt"
+license=('Apache-2.0')
+arch=('any')
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name//-/_}/${_name//-/_}-$pkgver.tar.gz")
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir/" dist/*.whl
+}
+
+sha256sums=('21e2b323aba833ecd1ea84746b55d486de5027f119987528ddb7b20c0272d10e')
+