summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c8a03efe092..5b0c6baca9d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,22 @@
pkgbase=python-assimulo
pkgname=('python-assimulo' 'python2-assimulo')
-pkgver=2.9
-pkgrel=4
+pkgver=3.0
+pkgrel=1
pkgdesc="A package for solving ordinary differential equations and differential algebraic equations"
url="http://www.jmodelica.org/assimulo"
arch=('i686' 'x86_64')
license=('LGPL')
-makedepends=('python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'gcc-fortran' 'sundials' 'lapack')
-source=("https://pypi.python.org/packages/4c/c0/19a54949817204313efff9f83f1e4a247edebed0a1cc5a317a95d3f374ae/Assimulo-2.9.zip" r831.patch r833.patch r836.patch r837.patch r838.patch r839.patch r840.patch r841.patch r845.patch)
-md5sums=('3f28fd98011d2ec7a01703a1ef1dff45' SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP)
+makedepends=('python-setuptools' 'python2-setuptools' 'cython' 'cython2' 'gcc-fortran' 'sundials' 'lapack' 'subversion')
+# PyPI archive is missing .pyf files
+# source=("https://pypi.io/packages/source/A/Assimulo/Assimulo-${pkgver}.tar.gz")
+source=("svn+https://svn.jmodelica.org/assimulo/tags/Assimulo-${pkgver}" sundials4.patch)
+md5sums=('SKIP' SKIP )
prepare() {
cd "${srcdir}"/Assimulo-$pkgver
- # https://trac.jmodelica.org/assimulo/changeset/845
- patch -p0 -i "${srcdir}"/r831.patch
- patch -p0 -i "${srcdir}"/r833.patch
- patch -p0 -i "${srcdir}"/r836.patch
- patch -p0 -i "${srcdir}"/r837.patch
- patch -p0 -i "${srcdir}"/r838.patch
- patch -p0 -i "${srcdir}"/r839.patch
- patch -p0 -i "${srcdir}"/r840.patch
- patch -p0 -i "${srcdir}"/r841.patch
- patch -p0 -i "${srcdir}"/r845.patch
+ # try to build with sundials 4.0
+ patch -p0 -i "${srcdir}"/sundials4.patch
}
build() {