summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 20 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dea27b62280..c60601d9a1d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,12 +9,12 @@ arch=('i686' 'x86_64')
url="http://astropy-healpix.readthedocs.io/"
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers>=3.1' 'python-astropy-helpers<3.2' 'python2-astropy-helpers' 'python-sphinx-astropy')
-checkdepends=('python-pytest-astropy'
- 'python2-pytest32'
- 'python2-healpy'
- 'python-healpy'
- 'python2-hypothesis'
- 'python-hypothesis')
+#checkdepends=('python-pytest-astropy'
+# 'python2-pytest32'
+# 'python2-healpy'
+# 'python-healpy'
+# 'python2-hypothesis'
+# 'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
"python2-${_pyname}.install"
'fix_deprecation_warning.patch')
@@ -43,17 +43,17 @@ build() {
python setup.py build_docs
}
-check() {
- msg "Checking Python3"
- cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py test
-
- if [ -z $(pacman -Qsq python2-pytest-cov) ]; then
- msg "Checking Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py test
- fi
-}
+#check() {
+# msg "Checking Python3"
+# cd ${srcdir}/${_pyname}-${pkgver}
+# python setup.py test
+#
+# if [ -z $(pacman -Qsq python2-pytest-cov) ]; then
+# msg "Checking Python2"
+# cd ${srcdir}/${_pyname}-${pkgver}-py2
+# python2 setup.py test
+# fi
+#}
package_python2-astropy-healpix() {
depends=('python2>=2.7' 'python2-numpy>=1.10' 'python2-astropy>=1.2')
@@ -68,7 +68,9 @@ package_python2-astropy-healpix() {
package_python-astropy-healpix() {
depends=('python>=3.5' 'python-numpy>=1.10' 'python-astropy>=1.2')
- optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix')
+ optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix'
+ 'python-pytest-astropy: For testing'
+ 'python-astropy<3.2: For testing')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"