summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b92c38d07967..2e9e9c6d9411 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,28 @@ pkgbase=python-astropy-healpix
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}" "python-${_pyname}-doc")
pkgver=0.4
-pkgrel=1
+pkgrel=2
pkgdesc="BSD-licensed HEALPix for Astropy"
arch=('i686' 'x86_64')
-url="http://astropy-healpix.readthedocs.io/en/latest/"
+url="http://astropy-healpix.readthedocs.io/"
license=('BSD')
-makedepends=('cython' 'cython2' 'python-astropy>=1.2' 'python2-astropy>=1.2' 'python-astropy-helpers>=3.1' 'python2-astropy-helpers' 'python-sphinx-astropy')
+makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers>=3.1' 'python2-astropy-helpers' 'python-sphinx-astropy')
checkdepends=('python-pytest-astropy'
-# 'python2-pytest'
-# 'python2-healpy'
+ 'python2-pytest32'
+ 'python2-healpy'
'python-healpy'
-# 'python2-hypothesis'
+ 'python2-hypothesis'
'python-hypothesis')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('59174f71ae6ef8b8969b2cfce702231e')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'fix_deprecation_warning.patch')
+md5sums=('59174f71ae6ef8b8969b2cfce702231e'
+ '71e532a1fed7a57d4ccf0d3e41035dd8')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
- sed -i -e '/auto_use/s/True/False/' setup.cfg
+ sed -i -e '/auto_use/s/True/False/' setup.cfg
+ patch -Np1 -i "${srcdir}/fix_deprecation_warning.patch"
cp -a ${srcdir}/${_pyname}-${pkgver}{,-py2}
}
@@ -39,21 +42,18 @@ build() {
}
check() {
-# msg "Checking Python3"
+ msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py test
-# msg "Checking Python2"
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py test
+ msg "Checking Python2"
+ cd ${srcdir}/${_pyname}-${pkgver}-py2
+ python2 setup.py test
}
package_python2-astropy-healpix() {
depends=('python2>=2.7' 'python2-numpy>=1.10' 'python2-astropy>=1.2')
- optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix'
- 'python2-pytest<3.7: For testing'
- 'python2-healpy: For testing'
- 'python2-hypothesis: For testing')
+ optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix')
cd ${srcdir}/${_pyname}-${pkgver}-py2
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"