summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65fa705af221..e1c64d53854c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@ url="http://astropy-healpix.readthedocs.io/"
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers>=3.1' 'python2-astropy-helpers' 'python-sphinx-astropy')
checkdepends=('python-pytest-astropy'
-# 'python2-pytest32'
-# 'python2-healpy'
+ 'python2-pytest32'
+ 'python2-healpy'
'python-healpy'
-# 'python2-hypothesis'
+ 'python2-hypothesis'
'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix_deprecation_warning.patch'
@@ -44,21 +44,20 @@ build() {
}
check() {
-# msg "Checking Python3"
+ msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py test
-# msg "Checking Python2"
-# cd ${srcdir}/${_pyname}-${pkgver}-py2
-# python2 setup.py test
+ if [ -z $(pacman -Qsq python2-pytest-cov) ]; then
+ msg "Checking Python2"
+ cd ${srcdir}/${_pyname}-${pkgver}-py2
+ python2 setup.py test
+ fi
}
package_python2-astropy-healpix() {
depends=('python2>=2.7' 'python2-numpy>=1.10' 'python2-astropy>=1.2')
- optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix'
- 'python2-pytest32: For testing'
- 'python2-hypothesis: For testing'
- 'python2-healpy: For testing')
+ optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix')
install=python2-astropy-healpix.install
cd ${srcdir}/${_pyname}-${pkgver}-py2