summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e9e9c6d9411..65fa705af221 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,15 +10,17 @@ url="http://astropy-healpix.readthedocs.io/"
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools' 'python2-numpy' 'python-astropy' 'python-astropy-helpers>=3.1' 'python2-astropy-helpers' 'python-sphinx-astropy')
checkdepends=('python-pytest-astropy'
- 'python2-pytest32'
- 'python2-healpy'
+# 'python2-pytest32'
+# 'python2-healpy'
'python-healpy'
- 'python2-hypothesis'
+# 'python2-hypothesis'
'python-hypothesis')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- 'fix_deprecation_warning.patch')
+ 'fix_deprecation_warning.patch'
+ 'python2-astropy-healpix.install')
md5sums=('59174f71ae6ef8b8969b2cfce702231e'
- '71e532a1fed7a57d4ccf0d3e41035dd8')
+ '71e532a1fed7a57d4ccf0d3e41035dd8'
+ '68d099a7f241f405c488da6f09618890')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -42,18 +44,22 @@ build() {
}
check() {
- msg "Checking Python3"
+# msg "Checking Python3"
cd ${srcdir}/${_pyname}-${pkgver}
python setup.py test
- msg "Checking Python2"
- cd ${srcdir}/${_pyname}-${pkgver}-py2
- python2 setup.py test
+# msg "Checking Python2"
+# cd ${srcdir}/${_pyname}-${pkgver}-py2
+# python2 setup.py test
}
package_python2-astropy-healpix() {
depends=('python2>=2.7' 'python2-numpy>=1.10' 'python2-astropy>=1.2')
- optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix')
+ optdepends=('python-astropy-healpix-doc: Documentation for Astropy-HEALPix'
+ 'python2-pytest32: For testing'
+ 'python2-hypothesis: For testing'
+ 'python2-healpy: For testing')
+ install=python2-astropy-healpix.install
cd ${srcdir}/${_pyname}-${pkgver}-py2
install -D -m644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"