summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9da33ae02637
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Stephanie Wilde-Hobbs (RX14) <steph@rx14.co.uk>
+pkgname=python-asyncio-dgram
+_name=asyncio-dgram
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="Higher level Datagram support for Asyncio"
+arch=('any')
+url="https://github.com/jsbronder/asyncio-dgram"
+license=('MIT')
+makedepends=('python-setuptools')
+depends=('python')
+source=("https://github.com/jsbronder/${_name}/archive/v${pkgver}.tar.gz")
+sha256sums=('f252b0976ec7100f7716fddc1804dd8a7732cb404d6ef95354a34096548acfae')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}