summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..03ab1b643d23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=python-asyncstdlib
+_name=${pkgname#python-}
+pkgver=3.9.2
+pkgrel=1
+pkgdesc="The missing toolbox for an async world"
+arch=('any')
+url="https://github.com/maxfischer2781/asyncstdlib"
+license=('MIT')
+depends=('python-typing_extensions')
+source=("https://pypi.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('2b9c729d238df39f4728f59303b152d5e9ff89860256d567609c91deba2848f3')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ export PYTHONHASHSEED=0
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}