summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a24ca89703b..fe665a729086 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,22 @@
pkgname=python-asysocks
_pkgname=asysocks
pkgver=0.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="Socks5/Socks4 client and server python library"
url="https://pypi.org/project/asysocks"
arch=('any')
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('03c9ba580d528c3e5ac11747b57b1935a1b9bf34abb47d82db79730351615a5a')
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}