summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56faad20623c..ecdff011903d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgbase=python-attrdict
pkgname='python-attrdict'
_name=${pkgname#python-}
pkgver=2.0.1
-pkgrel=4
+pkgrel=5
pkgdesc='A library that provides mapping objects that allow their elements to be accessed both as keys and as attributes.'
arch=('any')
url='https://pypi.org/project/attrdict/'
@@ -15,5 +15,9 @@ sha256sums=('35c90698b55c683946091177177a9e9c0713a0860f0e049febd72649ccd77b70')
package() {
cd attrdict-${pkgver}
+
+ # Fix from https://aur.archlinux.org/packages/python-attrdict#comment-855840 for Python 10.
+ find "${srcdir}/attrdict-${pkgver}" -type f -iname '*.py' -exec sed -i 's/collections/collections.abc/g' {} +
+
python setup.py install --root="$pkgdir" --optimize=1
}