summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 56c39f2e5d12..32949700fdab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,27 @@
_name=auditok
pkgname=python-auditok
pkgver=0.1.8
-pkgrel=1
+pkgrel=2
pkgdesc="An audio/acoustic activity detection and audio segmentation tool."
arch=('any')
url="https://github.com/amsehili/auditok"
license=('MIT')
depends=("python")
optdepends=("python-pydub: read audio files in popular audio formats (ogg, mp3, etc.) or extract audio from a video file."
-"python-pyaudio: read audio data from the microphone and play back detections."
-"python-matplotlib: plot audio signal and detections"
-"python-numpy: used for math operations instead of standard python if available.")
+ "python-pyaudio: read audio data from the microphone and play back detections."
+ "python-matplotlib: plot audio signal and detections"
+ "python-numpy: used for math operations instead of standard python if available.")
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
md5sums=('ce305a5c18fd2a472c103400a9a3b76a')
-
-prepare() {
- mv -v "${_name}-${pkgver}" "${pkgname}-${pkgver}"
- cd "${pkgname}-${pkgver}"
-}
-
build() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/$_name-$pkgver"
python setup.py build
}
package() {
- cd "$pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
}