summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f28938670d8f..c37b5def4418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
pkgbase='python-authlib'
pkgname=('python-authlib')
-_module='Authlib'
-pkgver='0.13'
+pkgver=0.14.3
pkgrel=1
pkgdesc="The ultimate Python library in building OAuth and OpenID Connect servers."
url="https://authlib.org/"
@@ -9,16 +8,15 @@ depends=('python')
makedepends=('python-setuptools')
license=('BSD')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('401a4a184379a6551b79af30243ce1ad56da0a8da5b4925e0be260f07ee40009')
+source=("https://files.pythonhosted.org/packages/source/A/Authlib/Authlib-$pkgver.tar.gz")
+sha256sums=('cc52908e9e996f3de2ac2f61bf1ee6c6f1c5ce8e67c89ff2ca473008fffc92f6')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "Authlib-$pkgver"
python setup.py build
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
+ cd "Authlib-$pkgver"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}