summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b300bab81b5b..cc12305a0b51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,28 +5,38 @@ _name=${pkgname#python-}
pkgdesc="Pythonic bindings for FFmpeg"
url="https://docs.mikeboers.com/pyav/"
-pkgver=9.2.0
+pkgver=10.0.0
pkgrel=1
arch=("x86_64" "i686")
license=("BSD")
+depends=(
+ "ffmpeg"
+ "python"
+ "python-numpy"
+ "python-pillow"
+)
makedepends=(
"cython"
"python-google-api-core"
"python-setuptools"
+ "python-wheel"
"pkgconf"
)
-depends=(
- "python"
- "ffmpeg4.4"
+checkdepends=(
+ "autopep8"
+ "flake8"
+ "python-editorconfig"
+ "python-isort"
+ "python-pytest"
+ "python-sphinx"
)
source=( "https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=("f2a7c226724d7f7745b376b459c500d9d17bd8d0473b7ea6bf8ddb4f7957c69d")
+b2sums=('0771fb37de072b63b8f276a2c3f76461af52910433793c7261f8216ab0af58ca46d8da871352d419c231a41fdb73b7e65f8d9eb71373f540cd3407148605ea74')
build() {
- export PKG_CONFIG_PATH="/usr/lib/ffmpeg4.4/pkgconfig"
cd "${srcdir}"/${_name}-${pkgver}
python setup.py build_ext --inplace
@@ -34,10 +44,11 @@ build() {
}
# test suite currently fails: https://github.com/PyAV-Org/PyAV/issues/876
-# check() {
-# cd "${srcdir}"/${_name}-${pkgver}
-# PYTHONPATH="$PWD/build/lib.linux-$CARCH-${python_version}" python ./setup.py pytest
-# }
+check() {
+ cd "${srcdir}"/${_name}-${pkgver}
+ export PYTHONPATH="${srcdir}/${_name}-${pkgver}/build/lib.linux-$CARCH-${python_version}"
+ python -m pytest
+}
package() {
cd "${srcdir}/${_name}-${pkgver}"