summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 5 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ffc2a4129279..970b9296aab9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,19 @@
# Maintainer: Damien Guihal <dguihal@gmail.com>
pkgbase=python-awscli-plugin-endpoint
-pkgname=('python-awscli-plugin-endpoint' 'python2-awscli-plugin-endpoint')
+pkgname=('python-awscli-plugin-endpoint')
pkgname=python-awscli-plugin-endpoint
-pkgver=0.3
+pkgver=0.4
pkgrel=1
pkgdesc="This awscli plugin provides service endpoint configure **per service** on profile."
arch=(any)
url="https://github.com/wbingli/awscli-plugin-endpoint"
license=('Apache License 2.0')
-makedepends=('python-setuptools' 'python2-setuptools')
+makedepends=('python-setuptools')
depends=('aws-cli>=1.11.0')
options=(!emptydirs)
-source=("https://github.com/wbinglee/awscli-plugin-endpoint/tarball/0.3")
-sha256sums=('0e9a2c9509b0a2bfafefcb543fa684974433de18099995d7f26284d2b1b0c61f')
-
-package_python2-awscli-plugin-endpoint() {
- pkgdesc="This awscli plugin provides service endpoint configure **per service** on profile. (python2 version)"
-
- cd "${srcdir}/wbingli-awscli-plugin-endpoint-5bd5eaa"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
-
- install -v -m755 -d "${pkgdir}/usr/share/doc/python2-awscli-plugin-endpoint"
- install -v -m644 README.md "${pkgdir}/usr/share/doc/python2-awscli-plugin-endpoint/"
-}
+source=("https://github.com/wbinglee/awscli-plugin-endpoint/tarball/${pkgver}")
+sha256sums=('f87c3e9e9f08047517848908c729411be055f7dc24cd6d2cff5b9a44dfc9afb5')
package_python-awscli-plugin-endpoint() {
pkgdesc="This awscli plugin provides service endpoint configure **per service** on profile. (python3 version)"