summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2630ef5d6805..6832dd681ab5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: pallxk <aur at pallxk dot com>
pkgname=python-azure-git
-pkgver=latest
-pkgrel=2
+pkgver=4.0.0.r2158.g619eb295a6
+pkgrel=1
pkgdesc="Microsoft Azure SDK for Python"
arch=('any')
url="https://github.com/Azure/azure-sdk-for-python"
license=('MIT')
-depends=('python-azure-storage' 'python-msrestazure')
+depends=('python-msrestazure')
makedepends=('git' 'python-setuptools')
provides=('python-azure')
-conflicts=('python-azure')
+conflicts=('python-azure' 'python-azure-storage')
source=("git+https://github.com/Azure/azure-sdk-for-python.git")
md5sums=('SKIP')
+pkgver() {
+ cd azure-sdk-for-python
+ git describe --long --tags --match azure_* | sed 's/^azure_//;s/-/.r/;s/-/./'
+}
+
build() {
cd azure-sdk-for-python
python setup.py build