summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7df775ee3469
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=python-bencode.py
+_pkgname=bencode.py
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='Simple bencode parser (for Python 2, Python 3 and PyPy)'
+arch=('any')
+url="https://github.com/fuzeman/bencode.py"
+license=('GPL')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://pypi.io/packages/source/${_pkgname::1}/${_pkngame}/${_pkgname}-${pkgver}.tar.gz")
+#source=("https://github.com/fuzeman/bencode.py/archive/${pkver}.tar.gz")
+
+build() {
+ cd "$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+sha256sums=('067cf936e29a7b698d2b4d00902343b78d434d73d837c33d6ca1a8be6038fe72')