summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f648d9d53a32..04d0cdc03ce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,27 @@
_pkgbase='better-exceptions'
pkgbase='python-better-exceptions'
pkgname=('python-better-exceptions' 'python2-better-exceptions')
-pkgver='0.1.6'
+pkgver='0.1.7'
pkgrel=1
pkgdesc="Pretty and useful exceptions in Python, automatically"
arch=('any')
url='https://github.com/Qix-/better-exceptions'
license=('MIT')
-depends=('python')
-makedepends=('python-setuptools' 'python2-setuptools')
-conflicts=('python-better-exceptions-git')
source=("https://github.com/Qix-/better-exceptions/archive/${pkgver}.tar.gz")
-sha256sums=('81dde2a736c336cc632b8ba9669435be4ef89fa4f6a754f457bd81420c72e499')
+sha256sums=('d98d98ba38a2cab8d849f4b5685ba684a4cef503f362077839c7dfcc4f69dcb5')
package_python-better-exceptions() {
+ depends=('python')
+ makedepends=('python-setuptools')
+ conflicts=('python-better-exceptions-git')
+
cd "${srcdir}/${_pkgbase}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}
package_python2-better-exceptions() {
depends=('python2')
+ makedepends=('python2-setuptools')
conflicts=('python2-better-exceptions-git')
cd "${srcdir}/${_pkgbase}-${pkgver}"