summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 393c16585334..67f673b5f3c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: 0b100100 <0b100100 at protonmail dot ch>
+# Maintainer: Kewl <xrjy@nygb.rh.bet(rot13)>
+# Contributor: 0b100100 <0b100100 at protonmail dot ch>
pkgname=python-binance
-pkgver=1.0.15
-pkgrel=3
+pkgver=1.0.19
+pkgrel=1
pkgdesc="An unofficial Python wrapper for the Binance exchange REST API"
arch=('any')
-url="https://github.com/sammchardy/python-binance"
+url="https://github.com/sammchardy/$pkgname"
license=('MIT')
-depends=('python' 'python-aiohttp' 'python-dateparser' 'python-pytz'
- 'python-requests' 'python-ujson' 'python-websockets')
+depends=('python' 'python-aiohttp' 'python-dateparser' 'python-pytz' 'python-requests' 'python-ujson' 'python-websockets' 'python-pycryptodome')
makedepends=('python-setuptools')
checkdepends=('python-pytest' 'python-requests-mock')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('2b059b763a380e9fe2529a6a9621acbbd180594ea54f1310ba0a8e266373ce1b13a9138bddd8232a77f1265216e0c3d5cb45e4a0c13840929a4e99c41a83829a')
+sha512sums=('e62485c6515b3bde696d3a9ef35300fb67ea40a6958d70781c77b77e52a834c2e5e6d7dc6287606b142dd37779a21af213fa85504fceea49cdd4729ca1ff6342')
build() {
cd "$pkgname-$pkgver"
@@ -29,5 +29,3 @@ package() {
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-
-# vim:set ts=2 sw=2 et: