summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 23 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 220160e289b8..d8c10a713d8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: Chris Brendel <cdbrendel@gmail.com>
-_pkgname=blis
-pkgname=python-${_pkgname}
-pkgver=0.9.0
+pkgname=python-blis
+_pkg="${pkgname#python-}"
+pkgver=0.9.1
pkgrel=1
pkgdesc='Fast matrix-multiplication as a self-contained Python library'
-arch=(x86_64 aarch64)
+arch=('x86_64' 'aarch64')
url='https://github.com/explosion/cython-blis'
-license=(MIT)
-depends=(
- cython
- python-numpy
- python-pytest
- python-hypothesis
-)
-makedepends=(python-setuptools)
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-b2sums=('c214630f5f2a1815eaaf6678db72356f042cc8223812f27d67d404b6658b8a5c47d38fd1b955dc29b6f3e7b3a2240e322e61c14737d92657d175651e5c495920')
+license=('MIT')
+depends=('python-numpy')
+makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz")
+sha256sums=('7ceac466801f9d97ecb34e10dded8c24cf5e0927ea7e834da1cc9d2ed3fc366f')
+
+prepare() {
+ cd "$_pkg-$pkgver"
+ sed -i '/packages=/c\packages=["blis"],' setup.py
+}
build() {
- cd "blis-${pkgver}"
- python setup.py build
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation
}
package() {
- cd "blis-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$_pkg-$pkgver"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "$_site/$_pkg-$pkgver.dist-info/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
}