summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5cf30eb0663..97b678bc224f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,30 @@
-# Maintainer: atomicfs
+# Maintainer: atomicfs <https://aur.archlinux.org/account/atomicfs>
+
pkgname=python-blkinfo
pkgver=0.2.0
pkgrel=2
pkgdesc="A python library to list information about all available or the specified block devices"
arch=('any')
url="https://github.com/grinrag/blkinfo"
-license=('GPL3')
-depends=('python' 'util-linux')
-_pkgname=blkinfo
-source=("${pkgname}::git+https://github.com/genalt/${_pkgname}#tag=${pkgver}")
+license=('GPL-3.0-only')
+depends=(
+ 'python'
+ 'util-linux'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+)
+source=("${pkgname}::git+${url}#tag=${pkgver}")
sha256sums=('SKIP')
+build() {
+ cd "${srcdir}/${pkgname}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "${srcdir}/${pkgname}"
- python setup.py install --root="${pkgdir}" --optimize=1
+ cd "${srcdir}/${pkgname}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}