summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96c569e4293a..6d1c530296b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: GI_Jack <GI_Jack@hackermail.com>
pkgname=python-bls
-pkgver=0.1.9
+_name=
+pkgver=0.1.10
pkgrel=1
pkgdesc="BLS12-381 and Signatures in Python"
url="https://github.com/zebra-lucky/python-bls"
@@ -10,10 +11,14 @@ license=('Apache2')
depends=('python')
makedepends=('python-setuptools' 'cython')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/zebra-lucky/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('c06658e4692ccf099494140ec76bf12274aeb6fc20d1e09fd6ebaeac94fb7b02')
+sha256sums=('5aaf5c668425116263bf6c3142d21b79d8c134a91c83a6169c8f2a08530b6839')
+build() {
+ cd "${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
package() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
}