summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e84f7188ea80..a80408ce3bc9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Excitable Snowball <excitablesnowball@gmail.com>
pkgname=python-bokeh
-pkgver=3.3.4
-pkgrel=1
+pkgver=3.4.1
+pkgrel=2
pkgdesc='Interactive Web Plotting for Python'
arch=('any')
url='http://bokeh.pydata.org/'
@@ -12,7 +12,7 @@ source=(
"https://pypi.io/packages/source/b/bokeh/bokeh-$pkgver.tar.gz"
)
sha256sums=(
- '73b7982dc2b8df15bf660cdddc8d3825e829195c438015a5d09824f1a7028368'
+ 'd824961e4265367b0750ce58b07e564ad0b83ca64b335521cd3421e9b9f10d89'
)
depends=('python-jinja'
'python-contourpy'
@@ -30,11 +30,15 @@ optdepends=('python-selenium: svg export'
'python-psutil: detailed memory logging'
'python-networkx: plot directly from NetworkX data'
'python-sphinx: support sphinx documentation')
-makedepends=('python-build' 'python-installer')
+makedepends=('python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools-git-versioning'
+ 'python-colorama')
build() {
cd "$srcdir/bokeh-$pkgver"
- python -m build --wheel
+ python -m build --no-isolation --wheel
}
package() {