summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a3450e075b0..4a574a083ca0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=python-briar-wrapper
conflicts=('python-briar-wrapper-git')
-pkgver=0.0.6
+pkgver=0.0.7
pkgrel=1
pkgdesc='A wrapper for the Briar headless API.'
arch=('any')
url='https://code.briarproject.org/briar/python-briar-wrapper'
license=('GNU Affero GPL')
-makedepends=('python-setuptools' 'python-dephell' 'git')
+makedepends=('python-setuptools' 'git' 'python-flit' 'python-toml')
depends=('python' 'python-websockets' 'python-requests' 'briar-headless')
source=("git+https://code.briarproject.org/briar/python-briar-wrapper.git#tag=${pkgver}"
'address_error.patch')
@@ -15,8 +15,9 @@ sha256sums=('SKIP'
prepare() {
cd "${pkgname}"
- dephell deps convert --prereleases --from pyproject.toml --to setup.py
- sed -E 's/packages=\[.*/packages=\["briar_wrapper", "briar_wrapper.models"\],/' -i setup.py
+ python -m flit build
+
+ tar -xvf dist/*.tar.gz --wildcards --no-anchored '*/setup.py' --strip=1
# fix uncaught OSError / 'Cannot assign requested address' while waiting for briar-headless to come up
patch -Np1 -i ../address_error.patch