summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4772df278cf4..6377ce1422fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
pkgname=python-briar-wrapper-git
_pkgname=python-briar-wrapper
conflicts=('python-briar-wrapper')
-pkgver=0.0.6.r1.g79a7889
+pkgver=0.0.7.r0.g8a59c71
pkgrel=1
pkgdesc='A wrapper for the Briar headless API.'
arch=('any')
url='https://code.briarproject.org/briar/python-briar-wrapper'
license=('GNU Affero GPL')
-makedepends=('python-setuptools' 'python-dephell' 'git')
+makedepends=('python-setuptools' 'git' 'python-flit' 'python-toml')
depends=('python' 'python-websockets' 'python-requests' 'briar-headless-git')
source=("git+https://code.briarproject.org/briar/python-briar-wrapper.git"
'address_error.patch')
@@ -21,8 +21,9 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- dephell deps convert --prereleases --from pyproject.toml --to setup.py
- sed -E 's/packages=\[.*/packages=\["briar_wrapper", "briar_wrapper.models"\],/' -i setup.py
+ python -m flit build
+
+ tar -xvf dist/*.tar.gz --wildcards --no-anchored '*/setup.py' --strip=1
# fix uncaught OSError / 'Cannot assign requested address' while waiting for briar-headless to come up
patch -Np1 -i ../address_error.patch