summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 23 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1e4dba208756..1a0b1976d652 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,44 @@
# Maintainer: András Wacha <awacha@gmail.com>
+# Contributor: Michał Wojdyła < micwoj9292 at gmail dot com >
pkgname=python-bumps
_name=${pkgname#python-}
-pkgver=0.7.11
+pkgver=0.9.2
pkgrel=1
pkgdesc="Data fitting with uncertainty analysis"
arch=(any)
url="https://github.com/bumps/bumps"
-license=('custom')
-makedepends=( python-setuptools
- python-sphinx
- python-nose
- python-docutils
- python-pygments
- 'python-jinja>=2'
-)
-depends=( python-numpy
- python-scipy
- python-matplotlib
- python-wxpython
- python-pyparsing
- python-periodictable
- python-scikit-learn
-)
-source=("https://github.com/${_name}/${_name}/archive/v${pkgver}.tar.gz"
+license=('LicenseRef-Public Domain')
+depends=(python-scipy
+ python-matplotlib
+ python-wxpython
+ python-periodictable
+ python-scikit-learn)
+makedepends=(python-setuptools
+ python-sphinx)
+#checkdepends=(python-nose)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/${_name}/${_name}/archive/v${pkgver}.tar.gz"
"bumps.patch")
-sha256sums=('f0c368d7beb4307297fb5298658921941a80c21e7bc52fb5dab1a1d1ef16d250'
- 'SKIP')
+sha256sums=('d4fa7c4c9bd07e3ef24a60ace3d4b17b3666258d51819b101a571ec07cd217c3'
+ '97eaae9fb391f9e0308bb969b4f5a07c6e137039c6c611814e96a5a027b7578b')
-prepare() {
- cd ${_name}-${pkgver}
- patch -p1 <../bumps.patch
-}
+#prepare() {
+# cd ${_name}-${pkgver}
+# # https://github.com/bumps/bumps/issues/129
+# patch -p1 <../bumps.patch
+#}
build() {
cd ${_name}-${pkgver}
python setup.py build
(cd bumps/dream && cc compiled.c -I ../../Random123/include/ -O2 -fopenmp -shared -lm -o _compiled.so -fPIC )
(cd doc && make html)
- (cd doc && make pdf)
+# (cd doc && make pdf)
}
-check() {
- cd ${_name}-${pkgver}
+#check() {
+# cd ${_name}-${pkgver}
# python test.py
-}
+#}
package() {
cd ${_name}-${pkgver}