summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f7a175eee19..9f8b959a8923 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=python-cadquery-git
-pkgver=2.0.1.r60.g2d721d0
+pkgver=2.0.1.r174.g65f9608
pkgrel=1
pkgdesc="A parametric CAD scripting framework based on PythonOCC built from git"
-arch=('any')
+arch=(x86_64)
url="https://github.com/CadQuery/cadquery"
license=('Apache')
-provides=('python-cadquery')
-conflicts=('python-cadquery')
-depends=(python-ocp python python-ezdxf)
-checkdepends=('python-pytest' 'python-pytest-cov' 'python-typing_extensions')
+provides=(python-cadquery)
+conflicts=(python-cadquery)
+depends=(python python-ocp python-ezdxf)
+checkdepends=(python-pytest python-pytest-cov python-typing_extensions)
source=("git+https://github.com/CadQuery/cadquery.git")
md5sums=('SKIP')
@@ -33,9 +33,10 @@ build() {
package() {
cd cadquery
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
+ # don't package test dir
_i_dir="${pkgdir}/$(python -c 'import sys; print(sys.path[-1])')"
rm -rf "${_i_dir}/tests"
-
}