summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 14 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f8b959a8923..3e280c45a613 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Grey Christoforo <first name at last name dot net>
pkgname=python-cadquery-git
-pkgver=2.0.1.r174.g65f9608
+pkgver=2.0.1.r184.gec9cd46
pkgrel=1
pkgdesc="A parametric CAD scripting framework based on PythonOCC built from git"
arch=(x86_64)
@@ -21,9 +21,15 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-check() {
+prepare() {
cd cadquery
- pytest -v --cov
+
+ # drop text() entirely
+ curl https://github.com/greyltc/cadquery/commit/48bab8ad9e176590f67980a263262b4c6b0b3198.patch | patch -p1
+
+ # loosen volume check restrictions
+ curl https://github.com/greyltc/cadquery/commit/3fdf585e640bbee0e41cfd1c3ba817e28e132937.patch | patch -p1
+ curl https://github.com/greyltc/cadquery/commit/a0ecf8ec23003859654087ba16343621aaecb8f3.patch | patch -p1
}
build() {
@@ -31,6 +37,11 @@ build() {
python setup.py build
}
+check() {
+ cd cadquery
+ pytest -v --cov
+}
+
package() {
cd cadquery
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build