summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8128aee1ba5..392a18732c32 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: A Frederick Christensen <aur@nosocomia.com>
# Contributor: Carsten Feuls <archlinux@carstenfeuls.de>
pkgname=python-caldav
+_name=${pkgname#python-}
pkgver=0.10
-pkgrel=1
+pkgrel=2
pkgdesc="A CalDAV (RFC4791) client library for Python"
arch=('any')
url="https://github.com/python-caldav/caldav"
@@ -12,20 +13,20 @@ depends=('python' 'python-lxml' 'python-requests' 'python-six' 'python-vobject')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
checkdepends=('python-icalendar' 'python-nose' 'python-pytest' 'python-tzlocal')
optdepends=('python-icalendar' 'python-tzlocal')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+source=("${_name}-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('23684644ec07e778956e27e454cf9c5fce89484ffec6312767969c20a1a3cdde')
build() {
- cd "caldav-$pkgver"
+ cd "${_name}-$pkgver"
python -m build --wheel --no-isolation
}
check() {
- cd "caldav-$pkgver"
+ cd "${_name}-$pkgver"
pytest
}
package() {
- cd "caldav-$pkgver"
+ cd "${_name}-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl
}