summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b10499e5674b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Chris Brendel <cdbrendel@gmail.com>
+# Python package author: Matthew Honnibal <matt@explosion.ai>
+pkgname=python-catalogue
+_origpkgname=catalogue
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Super lightweight function registries for your library "
+arch=("x86_64")
+url="https://github.com/explosion/catalogue"
+license=("MIT")
+depends=("python>=3.6")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/explosion/catalogue/archive/v$pkgver.tar.gz")
+md5sums=('e9e14d6aab9dad97770a8c1285f78400')
+
+package() {
+ cd "$_origpkgname-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}