summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 19 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2f4b8c7cbce..9fd85dcb238c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
pkgname=python-catboost-gpu-git
-pkgver=0.2
-pkgrel=2
+pkgver=r5141.a8f5a19bc
+pkgrel=1
epoch=0
pkgdesc="CatBoost is an open-source gradient boosting on decision trees library with categorical features support out of the box."
arch=('i686' 'x86_64')
@@ -17,8 +17,10 @@ replaces=()
backup=()
options=()
-source=("catboost::git+https://github.com/catboost/catboost.git")
-md5sums=('SKIP')
+source=('catboost::git+https://github.com/catboost/catboost.git'
+ 'cuda10deprecation.patch')
+md5sums=('SKIP'
+ '44fc5e88fd55a6d19d45fa61cdca6b70')
validpgpkeys=()
@@ -27,13 +29,22 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-package() {
+build() {
export YA_CACHE_DIR=/tmp/.ya
- cd $srcdir/catboost/catboost/python-package/catboost
- ../../../ya make -r -DUSE_ARCADIA_PYTHON=no -DUSE_SYSTEM_PYTHON=3.7 -DPYTHON_CONFIG=python3-config -DCUDA_ROOT=$CUDA_ROOT
+ cd "$srcdir/catboost"
+ git apply "$srcdir/catboost/cuda10deprecation.patch"
- cd ..
+ cd "$srcdir/catboost/catboost/python-package/catboost"
+ ../../../ya make -r \
+ -DUSE_ARCADIA_PYTHON=no \
+ -DPYTHON_CONFIG=python3-config \
+ -DHAVE_CUDA=yes \
+ -DCUDA_ROOT=$CUDA_ROOT
+}
+
+package() {
+ cd "$srcdir/catboost/catboost/python-package"
python3 mk_wheel.py -DCUDA_ROOT=$CUDA_ROOT
pip3 install --prefix $pkgdir/ catboost-*.whl
}