summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14dd2e3c8c59..6f9b3b9b9085 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
pkgname=('python-catkin_lint')
-pkgver='1.6.18'
-pkgrel=2
+pkgver='1.6.21'
+pkgrel=1
pkgdesc='Check catkin packages for common errors'
arch=('any')
url='https://github.com/fkie/catkin_lint'
@@ -11,17 +11,17 @@ depends=('python' 'python-catkin_pkg' 'python-lxml')
makedepends=('python-setuptools')
provides=('python-catkin-lint')
conflicts=('python2-catkin_lint' 'python-catkin-lint')
-source=("git+https://github.com/fkie/catkin_lint.git#tag=${pkgver}")
-sha256sums=('SKIP')
+source=("https://github.com/fkie/catkin_lint/archive/${pkgver}.tar.gz")
+sha256sums=('8abb5fccff2c77472f58ff94950f9001e3158ef9a6b7fd13714a2b43758f14c1')
_module='catkin_lint'
build() {
- cd "${srcdir}/${_module}"
+ cd "${srcdir}/${_module}-${pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_module}"
+ cd "${srcdir}/${_module}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
}