summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a309b2211328..53f9cd86f98d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=('python-catkin_pkg')
pkgver='0.4.24'
-pkgrel=1
+pkgrel=2
pkgdesc='Standalone Python library for the catkin package system'
arch=('any')
url='https://github.com/ros-infrastructure/catkin_pkg'
@@ -11,11 +11,18 @@ depends=('python' 'python-argparse' 'python-dateutil' 'python-docutils' 'python-
makedepends=('python-setuptools')
provides=('python-catkin-pkg')
conflicts=('python2-catkin_pkg' 'python-catkin-pkg')
-source=("https://github.com/ros-infrastructure/catkin_pkg/archive/${pkgver}.tar.gz")
-sha256sums=('57ea09fd51d9a67ccf5a0660a8f84794304182c4f644f27ad835a979567893b1')
+source=("https://github.com/ros-infrastructure/catkin_pkg/archive/${pkgver}.tar.gz"
+ "setuptools-replace-newlines-in-description.patch")
+sha256sums=('57ea09fd51d9a67ccf5a0660a8f84794304182c4f644f27ad835a979567893b1'
+ '0575506c2b25f44e6900f30c320b3dbdd6726174ab1ff45b22d8445b5a42f331')
_module='catkin_pkg'
+prepare() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ patch --forward --strip=1 -i "${srcdir}/setuptools-replace-newlines-in-description.patch"
+}
+
build() {
cd "${srcdir}/${_module}-${pkgver}"
python setup.py build