summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46c153626ee2..47fbfd627b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pipname=cattrs
pkgname=python-${_pipname,,}
-pkgver=1.9.0
-pkgrel=2
+pkgver=1.10.0
+pkgrel=1
pkgdesc='Complex custom class converters for attrs'
arch=(any)
url="https://github.com/Tinche/$_pipname"
@@ -11,15 +11,21 @@ license=(MIT)
depends=(python
python-attrs)
makedepends=(python-setuptools)
+checkdepends=(python-pytest)
_archive="$_pipname-$pkgver"
source=("https://files.pythonhosted.org/packages/source/${_pipname::1}/$_pipname/$_archive.tar.gz")
-sha256sums=('1ef33f089e0a494e8d1b487508356f055c865b1955b125c00c991a4358543c80')
+sha256sums=('211800f725cdecedcbcf4c753bbd22d248312b37d130f06045434acb7d9b34e1')
build() {
cd "$_archive"
python setup.py build
}
+build() {
+ cd "$_archive"
+ python setup.py test
+}
+
package() {
cd "$_archive"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build