summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD81
1 files changed, 17 insertions, 64 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 840b0e8ea8c1..e0e3f7a60f60 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,82 +1,35 @@
# Maintainer: Andy Botting <andy@andybotting.com>
-pkgname=('python-ceilometerclient'
- 'python2-ceilometerclient')
-pkgver='2.9.0'
-pkgrel='3'
+pkgname=python-ceilometerclient
+pkgver=2.9.1
+pkgrel=1
pkgdesc='Python client library for Ceilometer'
arch=('any')
-url="http://docs.openstack.org/developer/${pkgname}/"
+url="https://docs.openstack.org/$pkgname/latest/"
license=('Apache')
-makedepends=('python-setuptools'
- 'python2-setuptools')
-checkdepends=('python-pbr' 'python2-pbr'
- 'python-iso8601' 'python-iso8601'
- 'python-keystoneauth1' 'python2-keystoneauth1'
- 'python-oslo-i18n' 'python2-oslo-i18n'
- 'python-oslo-serialization' 'python2-oslo-serialization'
- 'python-oslo-utils' 'python2-oslo-utils'
- 'python-prettytable' 'python2-prettytable'
- 'python-requests' 'python2-requests'
- 'python-six' 'python2-six'
- 'python-stevedore' 'python2-stevedore'
- 'python-mock' 'python2-mock'
- 'python-subunit' 'python2-subunit'
- 'python-tempest'
- 'python-testrepository' 'python2-testrepository')
-source=("https://github.com/openstack/${pkgname}/archive/${pkgver}.tar.gz")
-sha512sums=('9955f683a07a2a5d7a65abe0a5100a2773f7938b69613a7ce24edcf7f42cd22d5e8a232ea5fe720715d8a344d16abf07c5288a9820f208c4815956cffd4f2702')
+depends=('python-pbr' 'python-iso8601' 'python-keystoneauth1'
+ 'python-oslo-i18n' 'python-oslo-serialization' 'python-oslo-utils'
+ 'python-prettytable' 'python-requests' 'python-six' 'python-stevedore')
+checkdepends=('python-mock' 'python-subunit' 'python-tempest'
+ 'python-testrepository')
+source=("https://github.com/openstack/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('76d379c51399233f5084ea7a75c2a2ebb1e178cf448601ef343b3b415c8ea42c90d3d287895b04b761b6e50e410a51be3ea8e3e65a5ef021f57ef7a27eafd55a')
-prepare() {
- cp -a "${srcdir}/${pkgname}-${pkgver}"{,-py2}
- export PBR_VERSION=$pkgver
-}
+export PBR_VERSION=$pkgver
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
python setup.py build
-
- cd "${srcdir}/${pkgname}-${pkgver}-py2"
- python2 setup.py build
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
python setup.py testr
-
- cd "${srcdir}/${pkgname}-${pkgver}-py2"
- PYTHON=python2 python2 setup.py testr
-}
-
-package_python-ceilometerclient() {
- depends=('python-pbr'
- 'python-iso8601'
- 'python-keystoneauth1'
- 'python-oslo-i18n'
- 'python-oslo-serialization'
- 'python-oslo-utils'
- 'python-prettytable'
- 'python-requests'
- 'python-six'
- 'python-stevedore')
- cd "${srcdir}/${pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
}
-package_python2-ceilometerclient() {
- depends=('python2-pbr'
- 'python2-iso8601'
- 'python2-keystoneauth1'
- 'python2-oslo-i18n'
- 'python2-oslo-serialization'
- 'python2-oslo-utils'
- 'python2-prettytable'
- 'python2-requests'
- 'python2-six'
- 'python2-stevedore')
- cd "${srcdir}/python-ceilometerclient-${pkgver}-py2"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- mv "${pkgdir}"/usr/bin/ceilometer{,2}
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
}
# vim:set ts=2 sw=2 et: