summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48274ba3f843..b142e8c57149 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Pavle Portic <archlinux@theedgeofrage.com>
-pkgbase='python-certifi-system-store'
-pkgname=('python-certifi-system-store')
-_module='certifi-system-store'
+pkgname='python-certifi-system-store'
+_module=${pkgname/python-/}
+_pypkgname='certifi_system_store'
pkgver='3021.3.16'
pkgrel=1
@@ -12,7 +12,7 @@ license=('MPL')
arch=('any')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-setuptools' 'python-wheel')
provides=('python-certifi')
conflicts=('python-certifi')
@@ -20,12 +20,11 @@ source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$
sha256sums=('603be2b260ae2d5d025f584a219087683ff2ddcd09325ebb56b172cd07877057')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py dist_info
+ python setup.py bdist_wheel
}
package() {
- depends+=()
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps "${srcdir}/${_module}-${pkgver}/dist/${_pypkgname}-${pkgver}-py3-none-any.whl"
}