summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90e5fb160d72..d2e35d563578 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,30 @@
pkgname=python-cffsubr
_pyname=${pkgname#python-}
-pkgver=0.2.9.post1
-pkgrel=2
+pkgver=0.3.0
+pkgrel=1
pkgdesc='Standalone CFF subroutinizer based on AFDKO tx'
-arch=(x86_64)
+arch=(any)
url="https://github.com/adobe-type-tools/$_pyname"
-license=(Apache)
-depends=(python
+license=(Apache-2.0)
+depends=(afdko
+ python
python-fonttools)
makedepends=(python-{build,installer,wheel}
python-setuptools-git-ls-files
python-setuptools-scm)
checkdepends=(python-pytest)
_archive="$_pyname-$pkgver"
-source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz")
-sha256sums=('6b31412dcf49c8fa84664bda867e2eddc55b6fe6fa696ff253c4f13a9ff2fc5c')
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.tar.gz"
+ devendor-tx.patch)
+sha256sums=('7745150bdb81679facdd11c1f3b87096c4f4dbd4957e8fcebb88c45687952efb'
+ '10ec393d97b10ab33ed475bcf6a2c9a5308ac1c82eccd1dd96c21f8e9da77e53')
+
+prepare() {
+ cd "$_archive"
+ rm -rf external _custom_build
+ patch -p0 -i ../devendor-tx.patch
+}
build() {
cd "$_archive"
@@ -26,8 +35,7 @@ build() {
check() {
cd "$_archive"
- local _pyver=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
- export PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$_pyver"
+ export PYTHONPATH="./src"
pytest tests
}