summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf460e750e59..8458603c5ca5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,16 @@
pkgname=python-cheetah3
_name=Cheetah3
-pkgver=3.1.0
-pkgrel=3
+pkgver=3.2.3
+pkgrel=1
pkgdesc="A Python 3-powered template engine and code generator"
arch=(x86_64)
url="http://www.cheetahtemplate.org"
license=(custom)
-depends=('python')
+depends=('python-setuptools')
optdepends=('python-markdown')
-provides=('cheetah3' 'python-cheetah3')
-conflicts=('cheetah3' 'python-cheetah3')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha512sums=('879de1b7a333def757a1618b7c28348d8b2f43a433aa8d5d9ee501619a854c514ca4a842f741bf4d272f5cc2defa137b741d2cc9648a3fc40dc2c4ab50692fac')
+sha512sums=('ebc735b59d61912679405469f9d509fc73bbdde51c414320994421849f4a02266d2c286c0f618cab2a592ab47ac0a4be9ec444fab75145a0c31dd0c3c39fc1e3')
build() {
cd "${srcdir}/${_name}-${pkgver}"
@@ -21,10 +19,12 @@ build() {
}
package() {
- msg "Install..."
cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- msg2 "Install copyright resources in /usr/share/licenses/${pkgname}..."
- install -Dm644 "${srcdir}/${_name}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ # Avoid conflict with python2-cheetah
+ for name in cheetah cheetah-analyze cheetah-compile; do
+ mv "${pkgdir}/usr/bin/${name}"{,3}
+ done
}