summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8bddd139cd47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: David Parrish <daveparrish@tutanota.com>
+
+# shellcheck disable=SC2034,SC2164
+
+pkgname=python-chromalog
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="Eases the use of colors in Python logging"
+url="https://github.com/freelan-developers/chromalog"
+makedepends=('python-setuptools')
+arch=('any')
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/freelan-developers/chromalog/archive/$pkgver.tar.gz")
+sha256sums=('7596837685b133549da367c752eeb2ff08091708dda9f2c1acce6be7ec938bbf')
+
+package() {
+ cd "${srcdir:?}/chromalog-$pkgver"
+ python setup.py install --root="${pkgdir:?}" --optimize=1 --skip-build
+ install -Dm644 "${srcdir:?}/chromalog-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}