summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8df0ced72007..e2565756b140 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
-# Maintainer: Hao Long <aur@esd.cc>
+# Maintainer: Roland Nagy <roliboy@protonmail.com>
+# Contributor: Hao Long <aur@esd.cc>
pkgname=python-cipheydists
-_pkgname=cipheydists
-pkgver=0.3.10
+pkgver=0.3.22
pkgrel=1
pkgdesc="A collection of sample distributions for use in Ciphey's frequency analysis"
arch=("any")
url="https://github.com/Ciphey/CipheyDists"
-license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "${url}/raw/master/LICENSE")
-sha256sums=('a9c6825b23daedb1af8da4d0730f15af8c065a8e80f4ec31ed1e1b2af0356918'
- '5cecf7f3f421c679134a8cc9af8fbebc7883195a8f26aab8e77f2e7460284dfe')
+license=("MIT")
+depends=("python")
+makedepends=(
+ "python-setuptools"
+ "python-poetry"
+)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=("3a433013e7c34c9525dd66a8e6182391d4e5cfcdb5c236792d1ffd883c0d49d1")
build() {
- cd ${_pkgname}-${pkgver}
- python setup.py build
+ cd "$srcdir/CipheyDists-$pkgver"
+ poetry build
+
+ cd dist
+ tar xf "cipheydists-$pkgver.tar.gz"
+ cd "cipheydists-$pkgver"
+ python setup.py build
}
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 ${srcdir}/LICENSE -t ${pkgdir}/usr/share/licenses/${pkgname}/
+ cd "$srcdir/CipheyDists-$pkgver/dist/cipheydists-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 "$srcdir/CipheyDists-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}